La scelta versione PHP per WordPress


La scelta versione PHP per WordPress : vi sembrerà una cosa da trascurare, roba da smanettoni, ma quando parliamo di WordPress la scelta di PHP è fondamentale.

La scelta versione PHP per WordPress

che significa scegliere la versione PHP ? ogni spazio hosting ha un file php.ini con settata la versione con cui i vostri script girano.  Esistono diverse versioni di PHP per rispondere a diverse esigenze. La versione va scelta in base allo script da utilizzare e al supporto del vostro server.

Quale versione php per WordPress

Attualmente, per wordpress 4.7 la versione ideale è la 7 e superiori. Questo non significa che WordPress non girerà su quelle inferiori, ma significa che magari girerà diversamente, con qualche worning e qualche funzione non più supportata. Volete sapere perchè l’hosting non aggiorna automaticamente questa funzione? Perchè non può sapere a priori quale installazione state facendo e se per wp o altri CMS.

Cambiare Versione php su Aruba condiviso

Vediamo come facciamo a cambiare versione su hosting Aruba: andiamo nella nostra area riservata,

pannello di controllo hosting aruba
pannello di controllo hosting aruba

cliccare su pannello di controllo

Poi andare Gestione Servizi Acquistati

gestione hostign linux
gestione hostign linux

Andare poi in strumenti ed impostazioni

Scelta della versione PHP

scelta della versione php
scelta della versione php

Bene, adesso poste scegliere la versione.

Su alcuni hosting condivisi potrebbe non essere disponibile la versione 7.

Cambiare Versione php in Cpanel

se avete un hosting con Cpanel, su alcuni hosting potrebbe essere disponibile una funzione per scegliere la versione php.

Andare in Cpnel

scelta php su cpanel
scelta php su cpanel

Andare su PhP manager, scegliere il dominio di riferimento e settare il giusto Php

Approfondimenti

Vi lascio gli approfondimenti per  Wordpress, in particolare dove si parla del codice e dei settaggi

https://wordpress.org/about/requirements/

Approfondimenti per quanto riguarda php 7

http://php.net/manual/en/migration70.new-features.php

 

La scelta versione PHP per WordPress
5 (100%) 1 vote

Domande o commenti su Wordpress?

4 comments on “La scelta versione PHP per WordPress

Avatar for Esperto SEO Mauro Madonna
Renzo

Su server Aruba ho aggiornato php alla versione 7.0. Il sito è sparito e mostra questo messaggio di errore: L’installazione PHP non ha l’estensione MySQL che è necessaria per utilizzare WordPress.
Idem con php7.1.
Qualche suggerimento?
Grazie in anticipo.

Reply
Avatar for Esperto SEO Mauro Madonna

Ciao Renzo, la prima cosa che mi viene da dirti è di controllare l’installazione WordPress, il Tema e i plugin, un componente non supporta php7, peggio ancora con php7.1.
quindi:
1)controllare che WP sia aggiornato
2)Controlla il tema, vai sul sito del costruttore e controlla che confermi il supporto a php7
3)elimina tutti i plugin non necessari e di quelli necessari verifica dal costruttore il supporto a php7

Reply
Avatar for Esperto SEO Mauro Madonna
Renzo

Grazie per la velocissima risposta! Si, credo proprio sia un problema legato ai temi utilizzati: Avevo fatto un test con php7 perchè richiesto da un nuovo tema che stavo installando. Ho attivato php7 senza nessun plugin attivo e con il tema Twenty Seventeen e mi dava errore, ho attivato il nuovo tema e tutto ha ripreso a funzionare.
Trovo solo strano che Twenty Seventeen che è un tema ufficiale di WP non supporti php7!?!
Ancora grazie.

Reply

Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *

Assistenza Wordpress

Wordpress Roma
Comunicazione Web srl
via di tor pignattara 139/141 roma, lazio 00177
Phone: 3398993565 madonna.mauro@gmail.com

Consulenza Wordpress

Consulenza Wordpress - WP esperti
Condivisioni